Co je plugin-container.exe a k čemu slouží

Pokud jste někdy koukali na seznam spuštěných procesů ve Windows, možná vás zaujal proces s názvem plugin-container.exe. Jak je z jeho popisu patrné, má co do činění s odděleným během zásuvných modulů, které je ve Firefoxu od verze 3.6.4. Obecně řečeno tento proces obaluje běh zásuvného modulu (jako je např. Adobe Flash), který, když spadne, nezpůsobí pád celého Firefoxu. Bližší informace o problematice naleznete na stránkách podpory Firefoxu.

Pokud se opakovaně setkáváte s pády zásuvného modulu či tím, že vám vytěžuje systémové prostředky, pak máte několik možností řešení. Prvně se ujistěte, že máte aktuální verzi zásuvného modulu. Jste-li například na stránce, kde běží animace pomocí Adobe Flash, která způsobuje problémy, je dobré se podívat, zda máte jeho aktuální verzi. Zda máte aktuální verze zásuvných modulů zjistíte například na stránce Mozilla Plugin Check.

Pakliže zjistíte, že nepoužíváte aktuální verzi zásuvného modulu, proveďte instalaci jeho nové verze. Ověřte též, že používáte aktuální verzi Firefoxu. Pokud ne, proveďte aktualizaci na novější verzi. Při řešení problému se zásuvným modulem si též můžete přečíst článek na stránkách podpory Firefoxu. V případě, kdy nevíte, jak dál, můžete provést vypnutí odděleného běhu zásuvného modulu pro konkrétní zásuvný modul.

V případě Adobe Flash to provedete tak, že přejdete na konfigurační stránku about:config, kde naleznete předvolbu dom.ipc.plugins.enabled.npswf32.dll a provedete její přepnutí na hodnotu false. Poté ukončete a znovu spusťte Firefox. Vzhledem k tomu, že se jedná o pokročilou konfiguraci, hrajte si s ní jen tehdy, když víte, co děláte. Pokud provedete vypnutí odděleného běhu Adobe Flash, přijdete o ochranu proti pádům Adobe Flash. V případě jeho pádu tak spadne i Firefox.

Přečtěte si také

8 odpovědí

Přidat komentář

  1. v6ak napsal(a) :

    Někdo se tu před časem zmínil, že oddělený proces by mohl vyřešit běh 32b i 64b pluginů ve Firefoxu. Jak to s tím vlastně vypadá?

    Odpovědět

  2. Luděk Janča napsal(a) :

    Nějak nechápu, kde je problém. Odděleně mi jedou jak 32bit (už jen jeden), tak 64bit pluginy. I před odděleným během mi jeli oba.

    Odpovědět

  3. josefec napsal(a) :

    v6ak pravděpodobně myslel běh 32bitových pluginů v 64bitovém Firefoxu. Jojo, taky by mě zajímalo, jestli toto bude pořešeno. Byla by to potom rychlejší cesta k přechodu na 64bitový Firefox, zatímco vývojáři pluginů by měli čas vytvořit 64bitové verze.

    Odpovědět

  4. v6ak napsal(a) :

    [3] Přesně tak. 64b system teprve plánuji. Uvidím, jak to bude s pluginy. Flash asi nahradím Gnashem, jako nouzovka to snad postačí. (Ostatně, ačkoli rozhodně nejsem jablíčkař, nemám flash o moc více rád.) Navíc je zřejmě spojen s nižšími bezpečnostními riziky.

    Odpovědět

  5. Luděk Janča napsal(a) :

    Používám 64bit OS už leta a „bez“ problémů. Mam 64bit FF a v něm 64bit Flash. Vše funguje. Bohužel se teď nedá 64bit varianta stáhnou a tak když bude někdo chtít, tak mu ji můžu nasdílet.

    Jinak se dá zprovoznit i 32bit Flash na 64bit FF, jen to není uplně bezproblémové. Dělá se to takto: http://joelp.cz/firefox_30_a_64bit__28
    Jen pokud používáte distribuční FF, není potřeba dělat symbolický odkaz, protože si to FF (alespoň u mě) vezme přímo z /usr/lib64/mozilla/plugins/

    Odpovědět

  6. v6ak napsal(a) :

    [5] No jo, ona totiž 64b verze není up to date. A nezáplatovanou verzi nechci. Dost možná se nakonec vykašlu na Flash i na 32b OS. Ještě uvidím, neznám moc kvalitu Gnashe.
    Ale jinak díky za info, o tom wrapperu jsem nevěděl. Až na ten odkaz, který je již nefunkční.

    Odpovědět

  7. Luděk Janča napsal(a) :

    [6] NSPluginWrapper máš určitě v distribuci 😉 Stačí nainstalovat.

    Odpovědět

  8. v6ak napsal(a) :

    [7] No dobře. Ještě uvidím, zda budu chtít Adobe Flash, možná v nějakém sandbox profilu budu mít Adobe Flash a v ostrém budu mít třeba Gnash. Snad tu nebude kolize. Uvidím.
    V distribuci to mám, i když jen v uživatelském „repozitáři“ (není pravým repozitářem): http://aur.archlinux.org/packages.php?O=0&K=NSPluginWrapper&do_Search=Go
    Jinak je to tu i předem připravené pro flash: http://aur.archlinux.org/packages.php?ID=6232

    Odpovědět

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *