Dnes vyjde Firefox 52


Dnes Mozilla uvolní aktualizaci Firefoxu na verzi 52, která vyjde i ve variantě ESR s rozšířenou podporou. Seznam změn ve verzi pro počítač není krátký:

  • odstraněna podpora zásuvných modulů přes NPAPI (vyjma Flashe)
  • pro omezení otisku prohlížeče bylo odstraněno API stavu baterie
  • Strict Secure Cookies zabrání nastavit cookies s příznakem secure stránkám načteným přes HTTP
  • výraznější varování při zadávání přihlašovacích údajů na webech bez HTTPS
  • multiprocesová architektura pro zařízení s Windows a dotykovou obrazovkou
  • posílání panelů mezi zařízeními pomocí služby Sync
  • drobná vylepšení rozhraní správce stahování
  • podpora WebAssembly pro větší rychlost her (vyzkoušejte!)
  • podpora CSS Grid Layout
  • vylepšený režim responzivního návrhu s novými funkcemi pro vývojáře
  • poslední verze s podporou Windows XP a Vista – uživatelé automaticky dostanou verzi s rozšířenou podporou, kde pro ně budou dostupné bezpečnostní aktualizace

Verze pro Android přidá tlačítka pro pozastavení a spuštění přehrávání videí nebo hudby skrze systémová oznámení a zmenší instalační balíček o 5 MB.

Firefox ve výchozím nastavení aktualizaci nainstaluje sám. Podrobnější informace o aktualizacích si můžete přečíst v nápovědě.

Přečtěte si také

46 odpovědí

Přidat komentář

  1. Calvin napsal(a) :

    Nic z čeho bychom si sedli na prdel pokud nejsem XP nebo Vistaci 🙂

    Odpovědět

  2. MartyMC napsal(a) :

    Co mě šokovalo, že Adobe už vytváří Flash i pro Linuxové prohlížeče. http://www.adobe.com/cz/software/flash/about/ Do nedávna byla pro Firefox jen zastaralá verze. Ovšem Google Chrome a Opera, a ostatní Chromium-based prohlžeče měli vždy nejnovější verzi i na Linuxu. Ovšem Firefox nikdy. Že by konečně přestali ignorovat kombinaci Linux a Firefox? Dokonce i na starší 32-bit architektuře mám nyní Flash verze 24. Co stalo? To jsou věci, Adobe?! … No, i tak mám Flash nastavený „spustit jen na vyžádání“. HTML5 video už je skoro všude, takže Adobe Flash už se moc nepoužívá. Ale i tak to potěšilo a šokovalo.

    Odpovědět

    1. Michal Vašíček napsal(a) :

      Nešlo o ignoraci Firefoxu ze strany Adobe, ale o ignoraci Linuxu jako takového, Google si Flash spravoval v Chromu sám (ovšem ne v Chromiu, kde to nedovolovala licence Flashe), zatímco Firefox se spoléhal přímo na Adobe. Google tak používal „svoji“ verzi zásuvného modulu všude, bez ohledu na platformu.

    2. Michal Stanke napsal(a) :

      Já spíš doufám, že Flash přestane být potřeba. 🙂

  3. IK napsal(a) :

    Duševní mrzáci bojující proti Flash. Zajděte si na psychiatrii pomatenci, patříte tam…

    Odpovědět

    1. Michal Stanke napsal(a) :

      Dneska je možná ještě někde potřeba, ale dlouhodobě to tak není.

  4. MaofKO napsal(a) :

    A doteraz sa v rámci sync panely nezdieľali? Veď sa to v nastaveniach dá zapnúť. Alebo je to nejaká iná vec?

    Odpovědět

    1. MaofKO napsal(a) :

      Pretože skúšam to medzi release v. 52 a nightly, no karty ani doplnky sa nesynchronizujú. Iba záložky.

    2. Michal Stanke napsal(a) :

      Panel můžete poslat (z kontextové nabídky nebo nabídky na Androidu) do jiného zařízení, kde se rovnou otevře.

  5. Kryštof napsal(a) :

    Zrovna dnes, když mám narozeniny. Lepší dárek jsem si snad ani nemohl přát… 😀

    Odpovědět

    1. Michal Stanke napsal(a) :

      Všechno nejlepší! 🙂

  6. Tom napsal(a) :

    Můžu poprosit, jak se mi na serveru bandzone.cz objeví „Včerejší nejhranější skladby“? V minulé verzi mi to šlo a teď mám jen prázdnej rámeček

    Odpovědět

    1. Michal Stanke napsal(a) :

      Nedělá to Adblock? Každopádně u mne to také nefunguje nikde ani po jeho vypnutí. Nejlépe napište rovnou na Bandzone.

  7. Petr napsal(a) :

    Dobrý den,
    dnes jsem si nainstaloval nový FF 52, ale cca po půldnu jsem ho musel odinstalovat. Na nékterých stránkách mi přestal fungovat výběr z comboboxů a kopírování textů (nešel ani vybrat). U všech se jednalo o HTTPS protokol a služby made in SAP.
    Po návratu k 51.0.1 všechno funguje, jak potřebuju. V tomto stavu je tedy pro mě přechod na vyšší, byť bezpečnější, verzi nepoužitelný.

    Odpovědět

    1. Petr napsal(a) :

      Ještě jsem zapomněl, že taky přestal fungovat výběr z více přihlašovacích certifikátů. Takže nevím, jakým jsem pŕihlášený 🙁

    2. Michal Stanke napsal(a) :

      Petr: Obraťte se prosím na https://www.mozilla.cz/podpora/. Většinou s podobnými věcmi pomůže obnova Firefoxu.

  8. Lukáš napsal(a) :

    Po aktualizaci na 52 se mi na stránkách, kde mám uloženo více uživatelských účtů (třeba Gmail) ihned po načtení nabízejí všechna uložená jména. Předtím jsem musel do políčka s loginem dvakrát kliknout. Dá se to nějak vrátit zpět? Zkoušel jsem signon.autofillForms, ale bez úspěchu.

    Odpovědět

    1. Michal Stanke napsal(a) :

      Lukáš: Obraťte se prosím na https://www.mozilla.cz/podpora/. Většinou s podobnými věcmi pomůže obnova Firefoxu.

  9. Zmizely ikony :-/ napsal(a) :

    Po restartu zmizí ikony všech tabů kromě vybraného. Takže zatímco dříve se mohl uživatel podle nich vizuálně orientovat, teď vidí v lepčím případě jen pár (někdy i jediný) znaků z [title] (mám běžně otevřeny desítky panelů, klidně přes sto, v několika oknech), v horším případě jen tři tečky z výpustky…

    Proč, proboha, musejí pořád ničit něco, co léta funguje?!

    Odpovědět

    1. Zmizely ikony :-/ napsal(a) :

      Ještě upřesním, že ty ikony nejsou vidět ani v pulldownovém seznamu tabů (stále přítomný díky „Permanent List-all-tabs Button“ rozšíření). Nejsou ani v TabHunteru. Prostě zatímco dříve byly zjevně nějak uloženy v rámci relace, tak nyní už nejsou.

    2. Calvin napsal(a) :

      Taky to nechápu stránk, které mám nechané po startu aplikace nepřipnuté jen jako panely. Mají default faviconu. Fakt tohle je děs….

  10. Calvin napsal(a) :

    Chápete někdo proč tam není odkaz na check verze flashe?

    Odpovědět

    1. Calvin napsal(a) :

      ve správci doplňků

  11. Jakub napsal(a) :

    Nová aktualizace mi smazala bez upozornění všechna uložená hesla a navíc ukazuje skoro všude otravnou hlášku o nezabezpečeném připojení. Tohle je podle mě pěkná podpásovka.

    Odpovědět

    1. Michal Stanke napsal(a) :

      Se ztracenými údaji se prosím obraťte na podporu (viz odkazy výše). Je tam už podobný dotaz https://support.mozilla.org/t5/Firefox/neaktualizace/td-p/1374597.

      Co se týče certifikátu, napište na podporu, jaká je konkrétní hláška po zobrazení rozšířených informací. Většinou dělá problém agresivní antivir. Prvotní návod na postup najdete po zadání té hlášky do vyhledávání na serveru podpory.

  12. KAB napsal(a) :

    No nevím jestli tohle je cesta – používám Firefox řadu let a dnes mi přestaly fungovat přístupy do bank a do různých systémů, přestaly třeba fungovat kamery atd. – to samé v polovině firmy. Takže rychle zkoušíme v jakém prohlížeči to půjde, aby firma nestála. Ani nevím jak tohle pojmenovat, žádné slušné slovo mě nenapadá zrovna.

    Odpovědět

    1. Michal Stanke napsal(a) :

      Co konkrétně znamená „přestaly fungovat“? Nějaká chybová hláška, nebo něco jiného?

    2. KAB napsal(a) :

      Už jsem na počítače nainstaloval staré verze FF (jen u sebe testuji ESR než taky nainstaluji starou verzi, aby to bylo všude stejné) a zakázal všude aktualizace, takže přesně se nepodívám – ale na https://www.tplinkcloud.com/ byla najednou hláška o nutnosti pluginu (nonie nebo tak nějak), co ale nešel ani po reinstalaci. A třeba na https://vkk.mol.hu/VKK2/www/login.jsp bylo jen prázdné okno.

      Myslím že webů a webových aplikací jsou mraky a přestat je zobrazovat a podporovat je absurdní. To my se musely ze dne na den všechny přeprogramovat a řada z nich už ani nemá vývojáře. No nic, řešení na čas mám za cenu nižší bezpečnosti.

    3. Michal Stanke napsal(a) :

      Jestli jsou v tom zásuvné moduly, informujte prosím ideálně správce a autory daných stránek. Moduly nepodporuje už žádný moderní webový prohlížeč (vyjma Flashe). Moderním myslím takový, který podporuje nové webové standardy, které z větší části dokáží moduly nahradit.

      Chápu, že někde to nestačí nebo není takový důvod současné řešení s pomocí modulů nahrazovat, a holt se vše nechává zastarat.

    4. DjVu napsal(a) :

      Která moderní technologie (případně který moderní webový prohlížeč) podporuje DjVu?

      Teď kvůli tomu v podstatě nefunguje žádný Kramerius, např. http://kramerius.nkp.cz/kramerius/MShowPageDoc.do?id=2665257&mcp=&idpi=19447835&author=

  13. George napsal(a) :

    Tak děkuji za novou aktualizaci, po*ral se mi tím celý Firefox, nejde spustit a po přeinstalaci nereaguje, teď musím používat Chrome, který je manipulačně uplně na nic.. Takže tleskám, nevím co s tím, už jsem to zkoušel několikrát – i celé znovu nainstalovat a nic.

    Odpovědět

    1. Michal Stanke napsal(a) :

      Pokud Firefox nejde spustit, začněte prosím touto nápovědou. A nebo se rovnou obraťte na fórum podpory.

  14. Karel6666 napsal(a) :

    – výraznější varování při zadávání přihlašovacích údajů na webech bez HTTPS

    První věc, kterou jsem vypnul po nainstalování nové verze. Spíš mě to otravuje. Stačilo by zvýraznit červenou v adresním řádku http.
    V další verzi to bude blikat, nebo to rovnou odmítne přihlášení bez https?

    Raději nech zapracují na lepším běhu. O e10s se tu básní 3 roky a stále mi hlásí „zakázáno doplňky“. Můj odhad byl správný – tak 5 let a bude to použitelný. Takže ještě 2 roky.
    Kdysi jsem Firefox nainstaloval a hned používal. Dnes po nainstalování to musim hodinu různě ladit a hrabat se v about:config, protože to jinak nejde nastavit.

    Hlavně nech se neopičí po Chrome a material designu.

    Odpovědět

Přidejte svůj komentář