Firefox 60 bude ESR a přidá konfiguraci pro nasazení ve firmách


Mozilla se rozhodla změnit původní plán a další verzí s rozšířenou podporou pro podniky (ESR) nebude Firefox 59, ale až následující verze 60, která vyjde 5. května 2018. Zároveň s tím tak dojde i k prodloužení podpory verze 52 o jeden cyklus do konce srpna.

Verze s prodlouženou podporou jsou cílené pro nasazení ve firmách, kde je potřeba delší dobu udržovat stabilnější prostředí. Do Firefoxu ESR se tak nedostávají nové funkce ani jiné větší změny. Po dobu podpory, které je něco mezi rokem a rokem a půl, dostává jenom bezpečnostní aktualizace. A právě pro podniky chce Mozilla do verze 60 přidat zajímavé funkce Enterprise Policies. Umožní hromadnou správu nastavení a třeba i vypnutí telemetrie nebo některých funkcí, blokování domén či omezení přístupu k about: stránkám Firefoxu jako about:config nebo about:addons.

Firefox 60 bude podporovat jak konfiguraci pomocí JSONu, tak využití skupin zásad (Group Policy Object) systému Windows. Pokud vás možnost nasazení Firefoxu ve firemním prostředí zajímá, můžete si více o podpoře GPO a konfigurace pomocí JSONu přečíst na MozillaWiki.

Přečtěte si také

11 odpovědí

Přidat komentář

  1. BobTehBuilder napsal(a) :

    Už jsem se těšil, že tam bude možnost vložení certifikátu vlastní certifikační autority (nebo aspoň použití certifikátů v systému, kam ho pomocí GPO dostanu). A zdá se, že nic.
    A to pomineme změnu jazyka uživatelského rozhraní podle nastaveného Display Language – to by bylo velmi krásné, jak u Firefoxu, tak Thunderbirdu. Příklad by si mohli vzít z LibreOffice, kde česká verze má i anglické jazykové rozhraní a přepne si to (lze i nastavit výslovně, co chci).

    Odpovědět

    1. Franta Hanzlík napsal(a) :

      Ta nemožnost importu certifikátu je ve FF pro widle? Protože po Linuxem to jde bez problémů snad odjakživa (import osobních, lidí i CA).

    2. BobTheBuilder napsal(a) :

      No, hlavně že „widle“, ale asi netušíte, co jsou Group Policy (GPO) a tak vám uniká podstata problému.
      Firefox se chová stejně jako v Linuxu a to je právě chyba. Takže třeba certifikát firemní certifikační autority si musí nastavit KAŽDÝ UŽIVATEL sám, a to pro Firefox zvlášť a pro Thunderbird taky zvlášť. Zkuste to prakticky dělat v prostředí, kde máte 4000 uživatelů, z nichž se každý rok několik set vymění.
      Tohle je vada Firefoxu od samého začátku.

  2. SpookY napsal(a) :

    Přeloženo do prostého jazyka – i v Mozille si uvědomili, že to se změnami, které přišly s 57čkou, totálně pohnojili. 🙂

    Odpovědět

    1. Ota Riebel napsal(a) :

      Přesně tak, stojí to za prd, nepodporuje spoustu pluginů, zejména mi vadí tile tabs, tá náhrada je totálně nepoužitelná. A to nemluvím o push upozornění… :-(((

  3. Guest napsal(a) :

    Certifikaty ide importovat z Windows cert store takto https://wiki.mozilla.org/CA:AddRootToFirefox

    Odpovědět

    1. BobTheBuilder napsal(a) :

      To jo, a zkoušel jste to v praxi? Mně se to zdá poněkud problematicky použitelné, nemluvě o tom, že to umožní jen import, ale ne případné odstranění takového certifikátu.
      V každém případě musíte každému uživateli něco nastavit, aby to začalo fungovat. Snad jen ten autoconfig.js by se dal přes GPO vnutit, ale ten zase funguje jen při vytváření nového profilu, nebo ne? Už je to nějakou dobu, co jsem to zkoušel.

  4. esr napsal(a) :

    Firefox který přišel s mým PC byl v kanálu release, změnil jsem kanál na esr, dal aktualizovat a postupně došel do verze 57, takže předvolba app.update.channel nepomohla. Jak se vrátit do kanálu esr bez stahování nového souboru esr ze stránek Mozilly?

    Odpovědět

    1. esr napsal(a) :

      Aha config nefunguje, musí se změnit channel-prefs.js, no tak kanál změněn ale už se nechce vrátit.

    2. Michal Stanke napsal(a) :

      esr: Pokud chcete používat Firefox ESR, je potřeba stáhnout instalaci z webu Mozilly (odkaz na https://www.mozilla.cz/stahnout/firefox/). ERS je verze 52 a pokud jenom změníte předvolbu, Firefoxu se pochopitelně sám „downgradovat“ neumí. Také si předem zazálohujte obsah profilu s vašimi daty. Downgrade není podporován a může dojít k poškození dat.

  5. esr napsal(a) :

    No tak jsem nakonec stáhnout musel. Ty zálohy hesel vždy dělám tak, že si je zobrazím v prohlížeči a použiju třeba výstřižky a udělám obrázek, pokud se nevejde udělám druhý. Už jsem jednou v dávných dobách narazil na problém, že záloha souboru pak v nové verzi nefungovala. Pak samozřejmě musím jít na stránku a provést přihlášení s novým uložením.

    Odpovědět

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *